帝国论坛帝国软件产品与服务帝国产品发布区如果整合其他系统并且编码不同,需要更新此文件 【20080805】 【本版专题贴子】  
主题:如果整合其他系统并且编码不同,需要更新此文件 【20080805】 [加入收藏夹]   

wm_chief
用户头衔:管理员

精华贴   :21
发贴数   :48945
经验值   :114169
注册时间:2002-10-30
信息 搜索 好友 发送悄悄话 精益求精-帝国网站管理系统7.5正式版开源发布】   [第 1 楼]
如果整合其他系统并且编码不同,需要更新此文件 【20080805】
由于 PHP 对 多字节字符集的支持存在问题,在各种编码相互转换过程中,有可能引发程序溢出和程序错误。此问题目前已经影响到 帝国CMS 中的会员整合接口的使用,如果是整合其他系统,并且被整合系统编码不同的话,需要打此补丁(如:GBK版整合UTF-8的会员系统或者UTF-8版整合GBK的会员系统)。

帝国CMS于2008-8-5 22:00修正了最新程序,此时间后安装和升级的用户(v5.0)将不用安装此补丁程序。

补丁修复方法:(适用于所有帝国CMS版本)
·修复时间:2008-8-5 22:00
·修复方法:修改e/class/user.php文件,找到:(72行左右)
                $str=$fun($targetcode,$code,$str);
        }
        return $str;
将他改为
                $str=$fun($targetcode,$code,$str);
        }
        return addslashes(stripslashes($str));
,然后保存文件即可修复。(推荐用dreamweaver编辑)

[该贴被修改 7 次,最后修改时间 2008-08-26 10:15:50 ]


[零基础入门教程] [模板制作教程] [采集使用教程]
2008-08-05 22:30:01 已设置保密 顶部 回复 引用 报告 编辑 删除

快速回复
内容

表情
使用EBB代码 使用smile代码 显示签名 自动分析url 自动分析img
     【进入高级模式】   (按 Ctrl+Enter 直接提交)
    顶部  加入收藏夹
关于帝国 | 广告服务 | 联系我们 | 法律声明 | 隐私条款 | 许可协议
Powered by: EBB Version 2.2.1